박정규 bagjunggyu 님의 블로그
이 블로그의 컴퓨터 관련 내용은 박정규 라이선스를 따릅니다.

전체보기 (296)

Burg설치, 설정, 테마, 제거 & Grub 다시 설치하기 view 발행 | Grub
박정규 2013.12.11 06:14
좋은정보감사합니다^^
만나서 반갑습니다 ^^
블로그 구경 잘하고 갑니다^^ 스크랩하고 가요^^
네^^ 건강하세요
좋은 자료 글 감사합니다^^
고맙습니다 ^__^
burg? 아마도 grub 를 뒤집은 거 겠죠? grub는 알고 있었는데 burg는 모르고 있었네요. :)
^__^
리눅스 첨 시작할 땐 뭐가 뭔지 아무것도 몰랐던 내용들이 이제는 눈에 들어와요~ 헤헤 ^^

근데 다른 페이지랑
sudo dcfldd if=/dev/zero of=/dev/sda bs=446 count=1
sudo dcfldd if=/dev/zero of=/dev/sda bs=512 count=1
bs= 숫자가 다른 차이가 뭔가요?
^___^
이 글에 간단한 MBR 청소에 대한 설명을 해두었는데요
http://blog.daum.net/bagjunggyu/139

MBR 의 크기와 구성에 대해서 살펴보면, MBR은 이렇게 구성되어져 있습니다.
446+64+2 = 512 bytes

1) 446 bytes - Bootstrap - 부트로더의 정보를 저장하는 공간입니다.
2) 64 bytes - 파티션 테이블 - 파티션 테이블의 정보를 저장합니다.
3) 2 bytes - Signature

입니다. 그래서 부트스트랩를 지우기 위해서 446 까지만 지웁니다^^
이번에 우분투 14.04 LTS를 EFI모드로 설치하고 Grub를 대체해서 Burg를 사용하려고 하는데, 기존방법처럼 하면 인식을 못하는 사태가 발생하더라고요..
혹시 방법이 있을까요? 지금까지 계속 EFI모드를 사용하지 않고 쓰다가 이번에 한번 교체중인데, 여기서 엄청나게 난항을 겪고 있습니다..ㅠㅠ
외국의 자료들에서는 대개 안되는 것으로 설명이되어져 있기는 하네요, 하지만 제 의견은 Burg가 오래되긴 했지만 안된다고는 못하겠구요, 그래도 지금은 제가 아무런 장비가 없어서 테스트를 해보면서 확인해 드릴 수가 없네요, 대안으로는 rEFInd가 있습니다.
일단 자료는 있네요, 2010년에 만들어진 burg-efi64 파일이 있기는 하네요
https://code.google.com/p/burg/downloads/list
이것으로 해보시고 알려주세요, 성공하신경우 글로 남기시면 그곳의 링크도 함께 알려주세요
다른 경우는 그냥 BIOS에서 EFI를 끄고 Legacy 모드로 부팅하게 해서 Burg를 읽어 들이는 것입니다.
이러면 EFI를 설치한 의미는 없어지기는 합니다.
  • CNBLACK
  • 2015.09.14 10:56
  • 신고
음... 반응이 없네요.. ㅠㅠ 일단 가능성이라도 주셔서 감사합니당..ㅎㅎ
위에서 사용하신 origanmi 테마를 적용하려 하니
This theme doesn't contain a theme.txt. Please look for the config file and rename it to "theme.txt"!
라는 에러메세지가 나와요ㅠ

theme 라는 파일은 분명히 있는데 txt로 확장자를 변경해야 하나 말아야하나 모르겠네요ㅠㅠ
부팅 화면에서 직접 테마를 바꾸면 그런일이 생깁니다.
위의 글 내용 처럼 시스템이 켜진 상태에서 F2나 t로 바꾼후에 재부티해야합니다.
그리고, 이렇게 되면 burg를 새로 설치해야 합니다.grub도 함께요
아래의 grub 와 burg새로 설치하기 과정을 참고해서 다시 설치하세요.
burg-mkconfig couldn't be executed successfully. error message:
Generating burg.cfg ...
/usr/sbin/burg-probe: error: cannot stat `/boot/burg/locale'.
No path or device is specified.
Try `/usr/sbin/burg-probe --help' for more information.
이런 오류가 뜨면 어떻게 해야할까요..ㅠㅠ 하모니카 최신버전입니다 ㅠ
  • 박정규
  • 2016.12.10 04:22
  • 신고
efi로 설치하셨으면 burg는 사용할   수 없습니다.
혹시 efi로 부트로더를 설치하셨나요?
이 글 참고하셔서 부트로더를 다시 정리(설치및 설정)해보세요
http://blog.daum.net/bagjunggyu/217
burg 를 받으려고 sudo add-apt-repository ppa:n-muench/burg -y && sudo apt-get update && sudo apt-get install burg burg-themes -y 했는데

gpg: keybox '/tmp/tmpc7v1a5_m/pubring.gpg' created
gpg: /tmp/tmpc7v1a5_m/trustdb.gpg: trustdb created
gpg: key A6804EA8EAE0D85C: public key "Launchpad PPA for Nate Muench" imported
gpg: Total number processed: 1
gpg:                                                         imported: 1
OK
기존:1 http://kr.archive.ubuntu.com/ubuntu yakkety InRelease
기존:2 http://kr.archive.ubuntu.com/ubuntu yakkety-updates InRelease                                        
기존:3 http://kr.archive.ubuntu.com/ubuntu yakkety-backports InRelease                                
기존:4 http://kr.archive.ubuntu.com/ubuntu yakkety-security InRelease                                    
무시:5 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety InRelease                                
무시:6 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety Release
무시:7 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main i386 Packages
무시:8 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main all Packages
무시:9 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-ko
무시:10 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-ko_KR
무시:11 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-en
무시:7 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main i386 Packages
무시:8 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main all Packages
무시:9 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-ko
무시:10 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-ko_KR
무시:11 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-en
무시:7 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main i386 Packages
무시:8 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main all Packages
무시:9 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-ko
무시:10 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-ko_KR
무시:11 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-en
무시:7 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main i386 Packages
무시:8 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main all Packages
무시:9 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-ko
무시:10 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-ko_KR
무시:11 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-en
무시:7 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main i386 Packages
무시:8 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main all Packages
무시:9 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-ko
무시:10 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-ko_KR
무시:11 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-en
오류:7 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main i386 Packages
     404     Not Found
무시:8 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main all Packages
무시:9 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-ko
무시:10 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-ko_KR
무시:11 http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety/main Translation-en
패키지 목록을 읽는 중입니다... 완료
W: The repository 'http://ppa.launchpad.net/n-muench/burg/ubuntu yakkety Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: http://ppa.launchpad.net/n-muench/burg/ubuntu/dists/yakkety/main/binary-i386/Packages 파일을 받는데 실패했습니다     404     Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

라고 뜨면서 설치가 안되네요..     해결방법 있나요? (Ubuntu MATE 16.10 사용중 이에요.)
  • 박정규
  • 2017.02.03 12:28
  • 신고
$ sudo gedit /etc/apt/sources.list.d/n-muench-ubuntu-burg-*.list
라고 입력하면 해당하는 내용이 뜰 겁니다.
그곳에서 코드네임을 yakkety에서 xenial로 바꾸고 저장하세요. 이렇게요
deb http://ppa.launchpad.net/n-muench/burg/ubuntu xenial main
# deb-src http://ppa.launchpad.net/n-muench/burg/ubuntu xenial main
그리고
$ sudo apt update
$ sudo apt install burg burg-themes
하면 설치될 겁니다.
감사합니다. Burg 를 잘 설치했습니다.
그런데 grub customizer 를 실행하면

burg-mkconfig 은 성공적으로 실행될 수 없습니다.
오류 메시지 : Generating burg.cfg ...
/usr/sbin/burg-probe : error : unknown filesystem.
이라고 뜨네요..
그런 경우는 grub-customizer를 이용할 수 없으니 직접 터미널에서 burg를 적용해보세요.
방법은 이 글을 참고하세요.
http://blog.daum.net/bagjunggyu/148
  • 박정규
  • 2017.02.13 08:41
  • 신고
아래에 같은 내용으로 문의 하신 분이 계셔서 함께 알아 봤지만.
확인해 보니 파일 시스템을 읽어 들이지 못하더군요,
여러가지 방법들을 시도해 봤지만 안되네요
우분투 16.10 이후 버전용으로 패키지 되기를 기다려야 겠네요.
전 shl님과 비슷하게 burg와 burg-themes를 설치하면서

yhs@yhs-P210-GEP3K:~$ sudo apt install burg burg-themes
패키지 목록을 읽는 중입니다... 완료
의존성 트리를 만드는 중입니다            
상태 정보를 읽는 중입니다... 완료
The following additional packages will be installed:
   burg-common burg-emu burg-pc burg-themes-common libsdl1.2debian
다음 새 패키지를 설치할 것입니다:
   burg burg-common burg-emu burg-pc burg-themes burg-themes-common
   libsdl1.2debian
0개 업그레이드, 7개 새로 설치, 0개 제거 및 0개 업그레이드 안 함.
0 바이트/13.5 M바이트 아카이브를 받아야 합니다.
이 작업 후 26.5 M바이트의 디스크 공간을 더 사용하게 됩니다.
계속 하시겠습니까? [Y/n] Y
패키지를 미리 설정하는 중입니다...
Selecting previously unselected package libsdl1.2debian:amd64.
(데이터베이스 읽는중 ...현재 204386개의 파일과 디렉터리가 설치되어 있습니다.)
Preparing to unpack .../0-libsdl1.2debian_1.2.15+dfsg1-4_amd64.deb ...
Unpacking libsdl1.2debian:amd64 (1.2.15+dfsg1-4) ...
Selecting previously unselected package burg-common.
Preparing to unpack .../1-burg-common_1.98+20100623-2.3_amd64.deb ...
Unpacking burg-common (1.98+20100623-2.3) ...
Selecting previously unselected package burg-pc.
Preparing to unpack .../2-burg-pc_1.98+20100623-2.3_amd64.deb ...
Unpacking burg-pc (1.98+20100623-2.3) ...
Selecting previously unselected package burg-emu.
Preparing to unpack .../3-burg-emu_1.98+20100623-2.3_amd64.deb ...
Unpacking burg-emu (1.98+20100623-2.3) ...
Selecting previously unselected package burg-themes-common.
Preparing to unpack .../4-burg-themes-common_1.98+20100623-2_all.deb ...
Unpacking burg-themes-common (1.98+20100623-2) ...
Selecting previously unselected package burg-themes.
Preparing to unpack .../5-burg-themes_1.98+20100623-2_all.deb ...
Unpacking burg-themes (1.98+20100623-2) ...
Selecting previously unselected package burg.
Preparing to unpack .../6-burg_1.98+20100623-2.3_amd64.deb ...
Unpacking burg (1.98+20100623-2.3) ...
Processing triggers for install-info (6.1.0.dfsg.1-8) ...
burg-themes-common (1.98+20100623-2) 설정하는 중입니다 ...
libsdl1.2debian:amd64 (1.2.15+dfsg1-4) 설정하는 중입니다 ...
burg-emu (1.98+20100623-2.3) 설정하는 중입니다 ...
Processing triggers for libc-bin (2.24-3ubuntu2) ...
Processing triggers for man-db (2.7.5-1) ...
burg-common (1.98+20100623-2.3) 설정하는 중입니다 ...
burg-themes (1.98+20100623-2) 설정하는 중입니다 ...
burg-pc (1.98+20100623-2.3) 설정하는 중입니다 ...

Creating config file /etc/default/burg with new version
/usr/sbin/burg-probe: error: unknown filesystem.
Auto-detection of a filesystem module failed.
Please specify the module with the option `--modules' explicitly.
burg (1.98+20100623-2.3) 설정하는 중입니다 ...

이렇게 설치가 끝나네요
얘전에 이글보고 설치할때는 파티션에 선택하고 확인 누르면 알아서 구성했는데
이번엔 제대로 설치되지 않네요
  • 박정규
  • 2017.02.12 19:47
  • 신고
두 분다 같은 증상이군요, 파일 시스템이 없다는 메시지가 나오네요.
우분투 16.04 계열은 아무 이상이 없으니, OS 버전에 의해서 생긴 파일 시스템 혹은 모듈과 연관된 이슈이려나요.
어떤 OS에서 이상이 생기던가요.
ubuntu gnome 16.10 amd64 입니다 원래 우분투에서도 실행해 봤는데 결과는 같네요.
  • 박정규
  • 2017.02.13 08:40
  • 신고
얼른 여러가지 방법들을 시도해 봤지만 안되네요
우분투 16.10 이후 버전용으로 패키지 되기를 기다려야 겠네요.
등록
텍스티콘 텍스티콘